Cấu Hình Vlan Trên Switch Cisco - Tăng Hiệu Năng, Giảm Chi Phí

Blog

Cấu hình Vlan trên Switch Cisco (1)

Cấu hình Vlan trên Switch Cisco mang lại cho bạn nhiều lợi ích như hiệu suất hoạt động cao, tính bảo mật chặt chẽ, tiết kiệm được chi phí,… Để tìm hiểu được các thức cấu hình mạng Vlan như thế nào trên thiết bị chuyển mạch Cisco thì hãy cùng NetworkPro tham khảo bài viết dưới đây nhé!

Thế nào là VLAN?

VLAN là một kỹ thuật về chuyển mạch lớp 2 và định tuyến của lớp 3 từ đó giới hạn miền đụng độ và miền quảng bá.

VLAN giúp bạn phân nhóm các user theo từng phòng ban (có mỗi VLAN là 1 subnet riêng biệt).

Ví dụ cụ thể: 1 switch có 24 cổng, ta chia

  • Cổng 1 – 8: phòng sale.
  • Cổng 9 – 16: phòng kinh doanh.
  • Cổng 17 – 24: phòng kỹ thuật.

VLAN đáp ứng được chất lượng dịch vụ QoS: Trong khi hệ thống mạng có khá  nhiều traffic như: Data, management, voice mà bạn cần ưu tiên traffic voice trước rồi mới tới data, management,… thì bạn phải gắn từng traffic cho mỗi VLAN (vì công nghệ share bandwidth có trong switch sử dụng ) và bạn hãy set độ ưu tiên cho từng VLAN.

Cấu hình Vlan trên Switch Cisco (2)

Phân loại Vlan hiện nay

VLAN chia làm 2 loại chính:

Loại 1: Static VLAN

  • VLAN tĩnh là cách thức phổ biến nhất để tạo ra VLAN và đây cũng là cách có tính bảo mật nhất.
  • Các cổng của VLAN luôn được duy trì cho đến khi quản trị viên thay đổi.

Loại 2: Dynamic VLAN

  • Thiết lập mạng VLAN dựa trên protocol, MAC address, application.
  • MAC address của máy đã được nhập vào cùng 1 ứng dụng để quản lý tập trung VLAN.
  • Nếu 1 node mạng đã được gắn vào 1 cổng và không được chỉ định trên switch, thì VLAN từ đó có thể dò tìm những địa chỉ phần cứng cũng như  ấn định cấu hình của các cổng chuyển đổi đúng mạng VLAN.

Những lợi ích của VLAN

  • Giảm chi phí.
  • Bảo mật.
  • Hiệu suất cao.
  • Nâng cao tốt hiệu suất làm việc của IT.
  • Giảm thiểu được tình trạng “Broadcast storm”.

Cấu hình Vlan trên Switch Cisco

Bước 1: Nhập lệnh để tạo Vlan

SW(config)#vlan n​

  • n thuộc 0 – 4095
  • VLAN 0 và 4095: không được sử dụng.
  • VLAN 1 : VLAN default
  • VLAN 2 – 1001: Normal range (có thể sử dụng được)
  • VLAN 1002 đến 1005: VLAN default, dùng để kết nối với các hệ thống mạng khác như: FDDI, token Ring …(không kết nối được system Ethernet)
  • VLAN 1006 – 4094: VLAN extended range (dùng cho các Switch Transparent)

Bước 2: Đặt tên cho VLAN (còn các VLAN default thì không đặt tên)

Switch(config-vlan)#name sale

Bước 3. Gán cổng vào VLAN

  • Chọn vào Interface

Switch(config)#interface f0/1

  • Chuyển Switch về mode access (mode access dùng để kết nối các end user)

Switch(config-if)#switchport mode access

  • Gán các cổng vào VLAN

Switch(config-if)#switchport access vlan n

Bước 4. Gán 1 range cổng vào VLAN

Switch(config)#interface range f0/1-8

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan n

Thiết lập mô hình mạng

Cấu hình Vlan trên Switch Cisco (3)

Tiến hành thực hiện theo các thao tác sau

  • Trên các Switch, cấu hình cơ bản.
  • Tạo ra các VLAN
  • Gán các cổng đến cùng một VLAN
  • Thêm, xoá và thay đổi các cổng
  • Kiểm tra cấu hình VLAN
  • Kích hoạt trunking trên các kết nối liên switch
  • Kiểm tra cấu hình trunk
  • Sao lưu cấu hình trunk

Hướng dẫn cách thực hiện “step by step”

Bảng địa chỉ IP và khởi tạo, gán các cổng

Cấu hình Vlan trên Switch Cisco (4)

Cấu hình cơ bản trên thiết bị

  • Cấu hình host name
  • Cấu hình pass chế độ EXEC là class
  • Cấu hình pass kết nối console là cisco
  • Cấu hình pass kết nối vty là cisco

Tạo các VLANs trên switch-S1

  • S1(config)#vlan 10
  • S1(config-vlan)#name faculty/staff
  • S1(config-vlan)#vlan 20
  • S1(config-vlan)#name students
  • S1(config-vlan)#vlan 30
  • S1(config-vlan)#name guest
  • S1(config-vlan)#vlan 99
  • S1(config-vlan)#name management
  • S1(config-vlan)#end

Kiểm tra các VLANs đã tạo trên switch-S1:

  • S1#show vlan brief

Cấu hình và đặt tên các VLANs trên switch-S2, S3 như trên S1.

Cấu hình các cổng trên switch-S2, S3:

S2:

  • S2(config)#interface range fa0/6, fa0/11, fa0/18
  • S2(config-if-range)#switchport mode access
  • S2(config-if-range)#no shutdown

S3:

  • S3(config)#interface range fa0/6, fa0/11, fa0/18
  • S3(config-if-range)#switchport mode access
  • S3(config-if-range)#no shutdown

Gán các cổng đến các VLANs trên switch-S2, S3:

S2:

  • S2(config)#interface range fa0/6-11
  • S2(config-if-range)#switchport access vlan 30
  • S2(config-if-range)#interface range fa0/11-17
  • S2(config-if-range)#switchport access vlan 10
  • S2(config-if-range)#interface range fa0/18-24
  • S2(config-if-range)#switchport access vlan 20
  • S2(config-if-range)#end
  • S2#copy running-config startup-config

Cấu hình tương tự trên S3

Gán VLAN management trên switch-S1, S2, S3

S1:

  • S1(config)#interface vlan 99
  • S1(config-if)#ip address 172.17.99.11 255.255.255.0
  • S1(config-if)#no shutdown

S2:

  • S2(config)#interface vlan 99
  • S2(config-if)#ip address 172.17.99.12 255.255.255.0
  • S2(config-if)#no shutdown

S3:

  • S3(config)#interface vlan 99
  • S3(config-if)#ip address 172.17.99.13 255.255.255.0
  • S3(config-if)#no shutdown

Cấu hình trunking và native VLAN cho các cổng trunking trên các switch-S1, S2, S3:

S1:

  • S1(config)#interface range fa0/1-5
  • S1(config-if-range)#switchport mode trunk
  • S1(config-if-range)#switchport trunk native vlan 99
  • S1(config-if-range)#no shutdown
  • S1(config-if-range)#end

S2:

  • S2(config)#interface range fa0/1-5
  • S2(config-if-range)#switchport mode trunk
  • S2(config-if-range)#switchport trunk native vlan 99
  • S2(config-if-range)#no shutdown
  • S2(config-if-range)#end

S3:

  • S3(config)#interface range fa0/1-5
  • S3(config-if-range)#switchport mode trunk
  • S3(config-if-range)#switchport trunk native vlan 99
  • S3(config-if-range)#no shutdown
  • S3(config-if-range)#end

Kết luận

Qua bài viết trên, NetworkPro cũng chia sẻ đến bạn cách cài đặt cấu hình Vlan trên Switch Cisco chi tiết nhất. Bạn hãy thao tác như trên cách trên với thiết bị mạng Cisco của mình. Chúc bạn tiến hành thao tác thành công.

Related News

0909 06 59 69

x